• Announcements

    • Brentonator

      Forum Rules (Please Read)

      Hello everyone and welcome to the No More Room In Hell Forums! We greatly appreciate your interest and support. Please feel free to begin post and become a part of this community. But please make sure that you read and understand the following rules so things can stay as clean and as orderly as possible around here. These rules are expected to be follow by any and all members at all times. Disobeying these rules will result in disciplinary action by a moderator. #1. Off color remarks are acceptable but can be deemed inappropriate at the discretion of the moderators. #2. Flaming and disrespecting other members of this community or this mod is strictly prohibited. #3. Please do not post links relating to warez or illegal downloading. #4. No offensive content is to be posted (gore, dead babies, porn). #5. Please do not spam topics to increase your post count. #6. No excessively large signatures. Signatures that violate this will be modified. #7. Signatures are not to be used as a spamming tool. If your signature's sole purpose is to annoy or distract other members, it will be removed. #8. Please do your part to be as friendly, respectful, and helpful to anyone and everyone on this forum. #9. Your posts may be removed at any time at our sole discretion. #10. Remember the terms of your registration...a copy is posted below but may not represent the latest version of our terms of use. #11. No advertising other communities or products. Have fun.
Sign in to follow this  
Followers 0
Paladin

Invalid SteamID User Ticket Solution

23 posts in this topic

Hello there,

It has recently come to our attention that an epidemic is sweeping the Source mod community. Players all across the globe are encountering this error when trying to play their favorite games:

STEAM-error1.jpg



For those of you experiencing this issue, fear not! There may be a solution.

1. Exit Steam if you haven't already.


2. Delete the config folder in your Steam directory.

3. Run Steam.exe
- Steam will redownload all of the files you deleted and verify the contents of your steamapps folder. (Credible sources say this process only takes a couple minutes)

4. Test the game!

*NOTE: This solution does not apply exclusively to PVK2. If you're having this issue in another Source mod, give it a try.

-----

Another solution that may work is listed here, in case if the above method doesn't work!

1. Close Steam.

2. Delete ClientRegistry.blob in your Steam folder

3. Run Steam.

-----

If both solutions above do not work, try this:

1. Delete the contents of your steam directory EXCEPT these files:
- The steamapps folder (and its contents)
- Steam.exe

2. Run Steam.exe (In the Steam folder, not the shortcut)
- Steam will redownload all of the files you deleted and verify the contents of your steamapps folder.

3. Load up NMRiH.

Share this post


Link to post
Share on other sites

thank you. had same problem. now it works again.

after deleting the files and restarting steam i got an email from steam support for "logging in with a new computer" autorization code (steam guard). works fine for me. finally i can test 1.02!

died after 5 minutes on solo cabin. looks good so far. xD

Share this post


Link to post
Share on other sites

Thanks good that we have all the help in this forum ^^. It started giving me this error for some weird reson do you know what starts it?

Share this post


Link to post
Share on other sites

You only need to delete the config folder in the Steam directory. I edited Paladin's original post to simplify this (people were getting confused).

Share this post


Link to post
Share on other sites

I'm having this problem for NMRiH and I followed each step precisely. Yet, this is not working for me. Are there are methods in which I can solve the issue? Thanks.

Share this post


Link to post
Share on other sites

Yeah, I was having this issue earlier today, but it stopped for me; however, I have been seeing a lot of people getting this issue on my servers. I thought it was an issue with my servers, but I can connect to it just fine, as can a number of other people. I had a friend that was having this issue, who also followed all the steps, but was still having the issue. I am curious to learn how to fix this :D If anyone can help, thanks!

Share this post


Link to post
Share on other sites

I've been having this problem all day. I did delete my Config folder in the Steam directory, and I did re-launch Steam again and I got the "Access from a new computer" email, but I am still seeing the "Invalid STEAM UserID Ticket"...

What can I do now? I really want to play NMRiH, but I can't...

I can only enter a map for a second or two then the "Invalid STEAM UserID" disconnects me...

Edited by SantanaTony

Share this post


Link to post
Share on other sites

**FIX**

1. Close Steam.

2. Delete ClientRegistry.blob

3. Launch and it will work.

Credit to TheAstuteOne for resolving the issue.

Share this post


Link to post
Share on other sites

Bumping since this issue is happening again for almost every mod lol

Share this post


Link to post
Share on other sites

I tried everything in this thread as well as deleting all files except "steamapps" and "Steam.exe" ...still not working. Anyone got a suggestion?

Share this post


Link to post
Share on other sites

I tried everything in this thread as well as deleting all files except "steamapps" and "Steam.exe" ...still not working. Anyone got a suggestion?

Try doing the same (fully exiting steam, deleting all files except steamapps and steam.exe) but instead of running your normal Steam shortcut to start the program, double click and run steam.exe

Share this post


Link to post
Share on other sites

Try doing the same (fully exiting steam, deleting all files except steamapps and steam.exe) but instead of running your normal Steam shortcut to start the program, double click and run steam.exe

I ended up using a quickfix exe someone made and that did it.

Share this post


Link to post
Share on other sites

da fuck this happened to me today playing. fuck source with a long dick

Share this post


Link to post
Share on other sites

Annoying and more annoying this issue....howerever the FIX posted by Fresh Meat actually works for me

Edited by Georgeos

Share this post


Link to post
Share on other sites

The delete clientregistry.blob works great! I started having the issue out of the blue yesterday, deleted that file, relaunched and it works perfectly. Thanks

Share this post


Link to post
Share on other sites

thanks bro, worked perfectly and took me minimal time and effort. churr and thanks again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0