• Announcements

    • Brentonator

      Forum Rules (Please Read)

      Hello everyone and welcome to the No More Room In Hell Forums! We greatly appreciate your interest and support. Please feel free to begin post and become a part of this community. But please make sure that you read and understand the following rules so things can stay as clean and as orderly as possible around here. These rules are expected to be follow by any and all members at all times. Disobeying these rules will result in disciplinary action by a moderator. #1. Off color remarks are acceptable but can be deemed inappropriate at the discretion of the moderators. #2. Flaming and disrespecting other members of this community or this mod is strictly prohibited. #3. Please do not post links relating to warez or illegal downloading. #4. No offensive content is to be posted (gore, dead babies, porn). #5. Please do not spam topics to increase your post count. #6. No excessively large signatures. Signatures that violate this will be modified. #7. Signatures are not to be used as a spamming tool. If your signature's sole purpose is to annoy or distract other members, it will be removed. #8. Please do your part to be as friendly, respectful, and helpful to anyone and everyone on this forum. #9. Your posts may be removed at any time at our sole discretion. #10. Remember the terms of your registration...a copy is posted below but may not represent the latest version of our terms of use. #11. No advertising other communities or products. Have fun.
Sign in to follow this  
Followers 0
Alex_2259

Leaks for no reason

2 posts in this topic

I am quite new to mapping, and like many, have learned from YouTube and other tutorials. I started editing an open source map I am using for a server that's a WIP, and have been pasting some buildings in, changing textures, re-designing rooms, etc. Nothing too complicated but not necessarily basic either.

 

My compile log shows a leak, so I went to the entity and loaded the but the line zig zags around and goes through a solid skybox. I tried to delete the entity (obviously, this won't work, as it just shifts to another one) and the problem of course, persisted. I have seen the same line exiting going up, down, etc. I have tried selecting all with the entity origins thing enabled, and there are none. I even at one point tried expanding my skybox as the leaks developed, but they just kept expanding.

 

I also tried enclosing the other 3d skybox in my map's main skybox. Also, the leaks are intermittent. Sometimes the compiler won't report them, but it usually does. (I have been finding false positives, as the leaks persist when I actually load the map up in game, with typical symptoms like water problems being a giveaway) I did also try copy/paste into another vmf file. Leak persisted.

Another odd thing is (as you can see, by my odd file name) I have quite a few backups of the map. The leak didn't really show itself until later stages in my map. Odd

VMF: http://www.mediafire.com/file/ubzeb9pfklz8z4r/rp_nova_prospekt_v8a-7-test-backup8-2.vmf

 

Compile log

** Executing...
** Command: "E:\SteamLibrary\steamapps\common\GarrysMod\bin\vbsp.exe"
** Parameters: -game "E:\SteamLibrary\steamapps\common\GarrysMod\garrysmod" "C:\Users\User\Desktop\rp_nova_prospekt_sources\rp_nova_prospekt_sources\vmfs\rp_nova_prospekt_v8a-7-test-backup8-2.vmf"

Valve Software - vbsp.exe (May 25 2017)
8 threads
materialPath: E:\SteamLibrary\steamapps\common\GarrysMod\garrysmod\materials
Loading C:\Users\User\Desktop\rp_nova_prospekt_sources\rp_nova_prospekt_sources\vmfs\rp_nova_prospekt_v8a-7-test-backup8-2.vmf
ConVarRef mat_reduceparticles doesn't point to an existing ConVar
material "maps/rp_downtown_v4c_r7/wood/woodstair002b_2250_-1322_-140" not found.
Material not found!: MAPS/RP_DOWNTOWN_V4C_R7/WOOD/WOODSTAIR002B_2250_-1322_-140
material "cs_italy/pwood1" not found.
Material not found!: CS_ITALY/PWOOD1
material "metal/forest_metal01a" not found.
Material not found!: METAL/FOREST_METAL01A
Could not locate 'GameData' key in e:\steamlibrary\steamapps\common\garrysmod\garrysmod\gameinfo.txt
Patching WVT material: maps/rp_nova_prospekt_v8a-7-test-backup8-2/nature/blendgrassgravel001b_wvt_patch
Patching WVT material: maps/rp_nova_prospekt_v8a-7-test-backup8-2/nature/blenddirtmud003a_wvt_patch
Patching WVT material: maps/rp_nova_prospekt_v8a-7-test-backup8-2/nature/red_grass_thin_wvt_patch
Patching WVT material: maps/rp_nova_prospekt_v8a-7-test-backup8-2/nature/canal_reeds_wvt_patch
fixing up env_cubemap materials on brush sides...
ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (1)
**** leaked ****
Entity light_spot (-3519.00 2991.67 889.00) leaked!
Processing areas...done (0)
Building Faces...done (0)
Chop Details...done (1)
Find Visible Detail Sides...
Merged 290 detail faces...done (1)
Merging details...done (0)
FixTjuncs...
PruneNodes...
WriteBSP...
done (1)
Creating default LDR cubemaps for env_cubemap using skybox materials:
   skybox/sky_day02_09_hdr*.vmt
 ! Run buildcubemaps in the engine to get the correct cube maps.
Creating default HDR cubemaps for env_cubemap using skybox materials:
   skybox/sky_day02_09_hdr*.vmt
 ! Run buildcubemaps in the engine to get the correct cube maps.
Finding displacement neighbors...
Finding lightmap sample positions...
Displacement Alpha : 0...1...2...3...4...5...6...7...8...9...10
Building Physics collision data...
done (1) (1473713 bytes)
Placing detail props : 0...1...2...3...4...5...6...7...8...9...10
Water found with no water_lod_control entity, creating a default one.
Compacting texture/material tables...
Reduced 6515 texinfos to 3446
Reduced 430 texdatas to 329 (21092 bytes to 16593)
Writing C:\Users\User\Desktop\rp_nova_prospekt_sources\rp_nova_prospekt_sources\vmfs\rp_nova_prospekt_v8a-7-test-backup8-2.bsp
7 seconds elapsed
  1.049162 -3.207047 0.000000
  -1.049033 -3.207047 0.000000
  -1.049033 3.206336 0.000000
  1.015345 -3.207047 0.000000
make_triangles:calc_triangle_representation: Cannot convert

** Executing...
** Command: Copy File
** Parameters: "C:\Users\User\Desktop\rp_nova_prospekt_sources\rp_nova_prospekt_sources\vmfs\rp_nova_prospekt_v8a-7-test-backup8-2.bsp" "E:\SteamLibrary\steamapps\common\GarrysMod\garrysmod\maps\rp_nova_prospekt_v8a-7-test-backup8-2.bsp"








 

Share this post


Link to post
Share on other sites

Check Radius Culling (letter R in red cycle) on top panel, it must be off when you compile map or you will have Leak for no reason. I had this problem too, maybe some hot key enable it

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0