• Announcements

    • Brentonator

      Forum Rules (Please Read)

      Hello everyone and welcome to the No More Room In Hell Forums! We greatly appreciate your interest and support. Please feel free to begin post and become a part of this community. But please make sure that you read and understand the following rules so things can stay as clean and as orderly as possible around here. These rules are expected to be follow by any and all members at all times. Disobeying these rules will result in disciplinary action by a moderator. #1. Off color remarks are acceptable but can be deemed inappropriate at the discretion of the moderators. #2. Flaming and disrespecting other members of this community or this mod is strictly prohibited. #3. Please do not post links relating to warez or illegal downloading. #4. No offensive content is to be posted (gore, dead babies, porn). #5. Please do not spam topics to increase your post count. #6. No excessively large signatures. Signatures that violate this will be modified. #7. Signatures are not to be used as a spamming tool. If your signature's sole purpose is to annoy or distract other members, it will be removed. #8. Please do your part to be as friendly, respectful, and helpful to anyone and everyone on this forum. #9. Your posts may be removed at any time at our sole discretion. #10. Remember the terms of your registration...a copy is posted below but may not represent the latest version of our terms of use. #11. No advertising other communities or products. Have fun.
Sign in to follow this  
Followers 0
Demo

Zombie Replacements

14 posts in this topic

Has anyone done it successfully without the game crashing? I'm trying to replace one of the zombies with a different model to fit the theme of my map, but every time it ends up crashing. I've been compiling them as "herby.mdl" and set it into nmrih > sdk > hl2mp > custom > my_custom_stuff > models > nmr_zombie, but as soon as the game tries to spawn a "herby" (which is actually now my custom model) I crash straight to desktop with no error.

Any idea what do?

Share this post


Link to post
Share on other sites

I got the qc set up correctly with all that info included. It's strange because I have no problems replacing survivors, but replacing zombies always seems to cause trouble.

Share this post


Link to post
Share on other sites

Yeah, and when the zombie goes to spawn (I have a button bound to spawning shamblers) it crashes my game. I think it might have *something* to do with the fact the zombie model's mass is 1, instead of 80. But I have no clue how to fix that. It happens regardless of which zombie model I try to replace.

Share this post


Link to post
Share on other sites

It may not recognize the nmr_shared.mdl being in a completely separate location. Have you tried just copypasta'ing the one out of the vpk into your directory?

Share this post


Link to post
Share on other sites
$cd "C:\Users\Name\Desktop\herby"

$modelname "nmr_zombie/herby.mdl"

$model "studio" "skeleton.smd"

$cdmaterials "models\nmr_zombie\skeleton\"

$bbox -16.0 -16.0 0.0 16.0 16.0 72.0



//NMR SHARED INFORMATION

$includemodel nmr_zombie/nmr_shared.mdl

//$sequence 360 "360" FPS 30 loop

//$sequence z_grab_01 "z_grab_01" FPS 15 snap



//Cra0 dev test animations not in common

//$sequence eating_idle "eating_idle" fps 30


Share this post


Link to post
Share on other sites
$cd "C:\Users\Name\Desktop\herby"
$modelname "nmr_zombie/herby.mdl"

$poseparameter "move_yaw" -180 180 0

$opaque

$cdmaterials "models\nmr_zombie\herby\"

$attachment "headshot_squirt" "ValveBiped.Bip01_Head1" 0 0 0 rotate 90 0 0

$surfaceprop "flesh"

$contents "solid"

$eyeposition 0 0 70

$hboxset "Zombie_PieceMeal"
$hbox 8 "ValveBiped.Bip01_Head1" -5.5 -6.54 -7.51 -2.5 3.46 7.49
$hbox 1 "ValveBiped.Bip01_Head1" -3.15 -7.54 -5.01 1.55 2.46 4.99
$hbox 1 "ValveBiped.Bip01_Head1" 1.5 -7 -5 4.5 3 5
$hbox 1 "ValveBiped.Bip01_Head1" 4.25 -6.8 -5 7.75 3.2 5
$hbox 2 "ValveBiped.Bip01_Spine1" -6.5 -1.84 -6.62 13.5 7.84 7.23
$hbox 4 "ValveBiped.Bip01_L_UpperArm" -1 -3.5 -2.5 11 3.5 2.5
$hbox 4 "ValveBiped.Bip01_L_Forearm" -0.5 -1.86 -1.9 10.5 3.11 2.36
$hbox 4 "ValveBiped.Bip01_L_Hand" 0 -1.78 -1 6 1.23 2
$hbox 5 "ValveBiped.Bip01_R_UpperArm" -1 -3.5 -2.5 11 3.5 2.5
$hbox 5 "ValveBiped.Bip01_R_Forearm" -0.5 -1.89 -1.6 10.5 3.09 2.66
$hbox 5 "ValveBiped.Bip01_R_Hand" 0 -1.78 -2.5 6 1.23 0.5
$hbox 6 "ValveBiped.Bip01_L_Thigh" 0 -4 -3.73 17.25 4 4.29
$hbox 6 "ValveBiped.Bip01_L_Calf" 0 -4.87 -3.54 17.25 3.18 2.63
$hbox 6 "ValveBiped.Bip01_L_Foot" -1.5 -2 -2.5 7.5 2 2.5
$hbox 7 "ValveBiped.Bip01_R_Thigh" 0 -4 -3.73 17.25 4 4.29
$hbox 7 "ValveBiped.Bip01_R_Calf" 0 -4.92 -3.12 17.25 3.25 2.65
$hbox 7 "ValveBiped.Bip01_R_Foot" -1.5 -2 -2.5 7.5 2 2.5
$skipboneinbbox


$includemodel "nmr_zombie/nmr_shared.mdl"

$ikchain "rhand" "ValveBiped.Bip01_R_Hand" knee 0.707 0.707 0
$ikchain "lhand" "ValveBiped.Bip01_L_Hand" knee 0.707 0.707 0
$ikchain "rfoot" "ValveBiped.Bip01_R_Foot" knee 0.707 -0.707 0
$ikchain "lfoot" "ValveBiped.Bip01_L_Foot" knee 0.707 -0.707 0

$ikautoplaylock "rfoot" 1 0.1
$ikautoplaylock "lfoot" 1 0.1

Try this one

Share this post


Link to post
Share on other sites

No dice, it wouldn't even compile without telling me that it couldn't find half those things.

Share this post


Link to post
Share on other sites

Yeah, bumping my own thread 6 months later, but it's working now. MDLDecompiler was just being a piece of shit, now I use the Crowbar Decompiler.

Share this post


Link to post
Share on other sites

Yeah, bumping my own thread 6 months later, but it's working now. MDLDecompiler was just being a piece of shit, now I use the Crowbar Decompiler.

Always use Crowbar, I thought I told everyone to do that now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0