• Announcements

    • Brentonator

      Forum Rules (Please Read)

      Hello everyone and welcome to the No More Room In Hell Forums! We greatly appreciate your interest and support. Please feel free to begin post and become a part of this community. But please make sure that you read and understand the following rules so things can stay as clean and as orderly as possible around here. These rules are expected to be follow by any and all members at all times. Disobeying these rules will result in disciplinary action by a moderator. #1. Off color remarks are acceptable but can be deemed inappropriate at the discretion of the moderators. #2. Flaming and disrespecting other members of this community or this mod is strictly prohibited. #3. Please do not post links relating to warez or illegal downloading. #4. No offensive content is to be posted (gore, dead babies, porn). #5. Please do not spam topics to increase your post count. #6. No excessively large signatures. Signatures that violate this will be modified. #7. Signatures are not to be used as a spamming tool. If your signature's sole purpose is to annoy or distract other members, it will be removed. #8. Please do your part to be as friendly, respectful, and helpful to anyone and everyone on this forum. #9. Your posts may be removed at any time at our sole discretion. #10. Remember the terms of your registration...a copy is posted below but may not represent the latest version of our terms of use. #11. No advertising other communities or products. Have fun.
Sign in to follow this  
Followers 0
Imman

Trouble starting the dedicated server

2 posts in this topic

I am trying to get my dedicated server running.

I am on Debian 7, 32 bit. I was following the instructions over at-

http://wiki.nomoreroominhell.com/wiki/Dedicated_Server_Setup

And I was able to trouble shoot some errors which occured first hand. Now I am stuck at the error-

./srcds_run: line 324: 26181 Segmentation fault      sleep $TIMEOUT
./srcds_run: line 324: 26182 Segmentation fault      $HL_CMD
Add "-debug" to the ./srcds_run command line to generate a debug.log to help with solving this problem
: Server restart in 10 seconds

I tried looking around and found a few threads. But, wherever I found this error, it was accompanied by "version `GLIBC_2.15' not found" error as well. And the discussion in those threads are on fixing the GLIBC_2.15 error and not the segmentation fault one.

Edit: Also, I tried using the 'nmrihserver Linux Server Manager'. But with that the script said that Game was started and alive. But I couldnt find it in the server list.

I checked around about it and then found that the nmrih-server.cfg file did not have the legacy and heartbeat cvars set in it. So, I added them and tried again, but it did not work.

I tried checking with Steam API to see if my server was up and visible to it and this is what I got,

{
	"response": {
		"success": true,
		"servers": [

		]
		
	}
}

I believe, I am supposed to get some server details after the "servers": tag, unfortunately I don't. So, I gave up on that, since it was all too automated and I did not know what was going wrong.

I started all over and am currently stuck at "line 324: Segmentation fault" as explained above. I have spent the entire day looking around to understand what the problem is, to no avail. So, I felt I might give it a shot asking it over here. Any advice would be helpful.

Edited by Imman

Share this post


Link to post
Share on other sites

Let's see what version of library is installed. Run this as root to see:

ldd --version

Maybe we can compare to a working server and see if you are using a different version of the library.

It's also possible to run strace on it to trace the system calls and see the last one before the crash. However, the output of strace is pretty verbose, so you may need to deal with that. To run the server with strace simply run the srcds command like normal, but with strace before it:

strace srds -console -game nmrih +map nmo_chinatown

This can give an idea of it the server is crashing based on touching the network, disk, or other subsystems.

Another random thing that comes to mind is AppArmor. It's possible that it's set to something aggressive and it's getting involved. You can try disabling it and see if it stops the server from crashing:

/etc/init.d/apparmor stop

I would probably leave AppArmor disabled until I had things working usually. Note that it will start next time the server boots unless you do further configurations.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0