• Announcements

    • Brentonator

      Forum Rules (Please Read)

      Hello everyone and welcome to the No More Room In Hell Forums! We greatly appreciate your interest and support. Please feel free to begin post and become a part of this community. But please make sure that you read and understand the following rules so things can stay as clean and as orderly as possible around here. These rules are expected to be follow by any and all members at all times. Disobeying these rules will result in disciplinary action by a moderator. #1. Off color remarks are acceptable but can be deemed inappropriate at the discretion of the moderators. #2. Flaming and disrespecting other members of this community or this mod is strictly prohibited. #3. Please do not post links relating to warez or illegal downloading. #4. No offensive content is to be posted (gore, dead babies, porn). #5. Please do not spam topics to increase your post count. #6. No excessively large signatures. Signatures that violate this will be modified. #7. Signatures are not to be used as a spamming tool. If your signature's sole purpose is to annoy or distract other members, it will be removed. #8. Please do your part to be as friendly, respectful, and helpful to anyone and everyone on this forum. #9. Your posts may be removed at any time at our sole discretion. #10. Remember the terms of your registration...a copy is posted below but may not represent the latest version of our terms of use. #11. No advertising other communities or products. Have fun.
RevenantGhost

nmrih_extract_preview problem

5 posts in this topic

nmrih_extract_preview is indeed meant to be viewed by all the players at once, but on my map it doesnt for some reason.

At first there was only 1 player spawner so i tought it could be the problem, so i've placed 8 player spawners and tried again, nothing changed.

Looks like the first player spawning sees the camera (wich is enabled at the begin of the objective 1), but is not always like that, sometimes is the second spawned one seeing the camera and not the first, looks random...

There's no flag to set if is for all the players or for one, so i suppose it is multiplayer by default, but looks like is not.

I also have another camera that enables when i open a door, same goes with it, only one at once can see it, usually the first one spawned.

Can someone please explain me why those cams are not working?

Share this post


Link to post
Share on other sites

I think that its a bug in the new patch because I was running my servers and when I joined only I could see the extraction cam no one else did. And I was playing on nms_mcc_diablo. Idk what causes the problem to appear.

Share this post


Link to post
Share on other sites

I think that its a bug in the new patch because I was running my servers and when I joined only I could see the extraction cam no one else did. And I was playing on nms_mcc_diablo. Idk what causes the problem to appear.

That's not an official map i think, the bug should happen in an official map to be a REAL bug... Hopefully some dev will reply something here, to give info about the bug and when is gonna be fixed...

Share this post


Link to post
Share on other sites

I have the same problem. I thought the nmrih_extract_preview would affect all players, but it only affects one. I was trying to use it for a small cutscene, but nope. RevenantGhost, did you find any solution?

Share this post


Link to post
Share on other sites

the entity "nmrih_extract_preview" is meant for use with extraction.

to trigger the cam for every player you must use "wave_controller > OnCustomWinBegin > Start".

It is not meant to be used as a cam you can trigger all the time and thats why it is not working correct.

(i might be wrong)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now