• Announcements

    • Brentonator

      Forum Rules (Please Read)

      Hello everyone and welcome to the No More Room In Hell Forums! We greatly appreciate your interest and support. Please feel free to begin post and become a part of this community. But please make sure that you read and understand the following rules so things can stay as clean and as orderly as possible around here. These rules are expected to be follow by any and all members at all times. Disobeying these rules will result in disciplinary action by a moderator. #1. Off color remarks are acceptable but can be deemed inappropriate at the discretion of the moderators. #2. Flaming and disrespecting other members of this community or this mod is strictly prohibited. #3. Please do not post links relating to warez or illegal downloading. #4. No offensive content is to be posted (gore, dead babies, porn). #5. Please do not spam topics to increase your post count. #6. No excessively large signatures. Signatures that violate this will be modified. #7. Signatures are not to be used as a spamming tool. If your signature's sole purpose is to annoy or distract other members, it will be removed. #8. Please do your part to be as friendly, respectful, and helpful to anyone and everyone on this forum. #9. Your posts may be removed at any time at our sole discretion. #10. Remember the terms of your registration...a copy is posted below but may not represent the latest version of our terms of use. #11. No advertising other communities or products. Have fun.
Sign in to follow this  
Followers 0
MrPolarBearJ

Black And Purple Texture Errors

16 posts in this topic

So I got a few skins on my server and the models show up, but they only show up with black and blue texture tiles. I have been looking on google for how to fix it, but have had no luck.

Plugins: Sm_skinchooser (HL2:DM Edition)

I compiled the folder into a .vpk since I read that in a TuT, but that was for HL2:DM. So I thought it would be the same concept.

Edit: Got textures working, and I meant black and purple tiles. I will do a small TuT so people can get their skins to work in-case they need to test them, or get the same plugin that I have.

Edited by MrPolarBearJ

Share this post


Link to post
Share on other sites

Black and Blue? No clue. Source usually register missing textures with black and purple.

Also post some screens of your issues, not just folder areas.

Share this post


Link to post
Share on other sites

I'm trying to understand this. Are you trying to use custom counterstrike source models as nmrih player models? like "slow/banana_joe"?

Share this post


Link to post
Share on other sites

I got the textures to work, you don't make a custom folder, it messes everything up. You just make a model and materials folder inside nmrih and it works perfectly after a little bit of coding. Just need to figure out how to make the animations for the arms, so they hold their guns and look like they are running, like normal characters. Any hints on how to do that? Or which files control this? Right now they hold the guns at their feet and have no animation effects.

Share this post


Link to post
Share on other sites

You've got the mesh rigged to the same skeleton as nmrih characters, right?

Share this post


Link to post
Share on other sites

You've got the mesh rigged to the same skeleton as nmrih characters, right?

I am not sure, I got the skins off a site: http://s-low.net/forum/index.php?sid=d0490e93c76201037436008a9f84018b

Here is an example of one I am using: http://s-low.net/forum/viewtopic.php?f=6&t=887&sid=d0490e93c76201037436008a9f84018b

f5sy.png

Edited by MrPolarBearJ

Share this post


Link to post
Share on other sites

You need to rerig or hack them onto our skeleton for them to display the same animations.

Share this post


Link to post
Share on other sites

Decompile the mdls for any player, load the smds in a modelling/animation program (EG. 3DS Max, Blender, Cinema 4D), align your mesh on our skeleton, if default pose matches the player, then you can rig it, if not align your skeleton over the pose as best as you can.

Then there is two options. Save the current pose on model and rerig it onto our skeleton manually.

Or

Parent the bones from existing skeleton onto our skeleton (hacking it).

After that, export smds and compile the model again. It should work.

Share this post


Link to post
Share on other sites

You need to open nmrih_dir.vpk (probably with GCFscape) and navigate to models/player.

Here you will just have to choose your pick. Not sure which one is latest, think it is Bateman.

Share this post


Link to post
Share on other sites

I have been playing with this all day and looking for a video guide or something to help me walk thru it. So far with one custom model and bate model, they all line up, but I don't know how to do the bone thing or the skeleton model. I am using blender, but I can't seem to figure it out.

Share this post


Link to post
Share on other sites

I do not know much about blender. Try asking Payne on the team or search for some tutorials etc.

Share this post


Link to post
Share on other sites

I do not know much about blender. Try asking Payne on the team or search for some tutorials etc.

Ya I got it figured out for the most part, just need to fix the way they hold the gun, otherwise they are perfect.

Share this post


Link to post
Share on other sites

After "fixing" the black and purple big screen error by disabling shaders i know have the following problem:
20131201_00008.jpg20131201_00010.jpg
I do not know how to describe it with words, but everywhere the 3d modles appear as big blinking ERROR texts, on every map.
My friend an I downloaded the latests standalone of NMRIH and we both have the same issues.

Picture links: Pic1 Pic2
Anyone knows a fix?

Edited by Setup

Share this post


Link to post
Share on other sites

Check y

After "fixing" the black and purple big screen error by disabling shaders i know have the following problem:
20131201_00008.jpg20131201_00010.jpg
I do not know how to describe it with words, but everywhere the 3d modles appear as big blinking ERROR texts, on every map.
My friend an I downloaded the latests standalone of NMRIH and we both have the same issues.

Picture links: Pic1 Pic2
Anyone knows a fix?

Check your other thread that you posted. If you are the server owner, I can tell you how to fix it. Unless this is on all servers.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0