• Announcements

    • Brentonator

      Forum Rules (Please Read)

      Hello everyone and welcome to the No More Room In Hell Forums! We greatly appreciate your interest and support. Please feel free to begin post and become a part of this community. But please make sure that you read and understand the following rules so things can stay as clean and as orderly as possible around here. These rules are expected to be follow by any and all members at all times. Disobeying these rules will result in disciplinary action by a moderator. #1. Off color remarks are acceptable but can be deemed inappropriate at the discretion of the moderators. #2. Flaming and disrespecting other members of this community or this mod is strictly prohibited. #3. Please do not post links relating to warez or illegal downloading. #4. No offensive content is to be posted (gore, dead babies, porn). #5. Please do not spam topics to increase your post count. #6. No excessively large signatures. Signatures that violate this will be modified. #7. Signatures are not to be used as a spamming tool. If your signature's sole purpose is to annoy or distract other members, it will be removed. #8. Please do your part to be as friendly, respectful, and helpful to anyone and everyone on this forum. #9. Your posts may be removed at any time at our sole discretion. #10. Remember the terms of your registration...a copy is posted below but may not represent the latest version of our terms of use. #11. No advertising other communities or products. Have fun.
Sign in to follow this  
Followers 0
ashton93

Zombies are spawning - but not moving

5 posts in this topic

Hi, first post here!

Figured I'd create a small survival map now that I've got the feeling of the game (I really like it) and it's all going good. Well, up to the point where I'm going to add zombies! I've followed every tutorial and generated nav-meshes, added an overlord-helper, a wave-controller and also func_zombie_spawns. The zombies are spawning fine, but they simply won't move unless I anger or see them in some way. If I'm not seeing them, they simply stand in their corner doing nothing.

The zombie-brushes are raised over displacements, could this be a problem? I commited a sin and de-compiled an official map to see if I could find any differences in the method. And well, I didnt see anything special. Tried searching up this problem too, with no luck.

Any help?

Edited by ashton93

Share this post


Link to post
Share on other sites

Hi, first post here!

Figured I'd create a small survival map now that I've got the feeling of the game (I really like it) and it's all going good. Well, up to the point where I'm going to add zombies! I've followed every tutorial and generated nav-meshes, added an overlord-helper, a wave-controller and also func_zombie_spawns. The zombies are spawning fine, but they simply won't move unless I anger or see them in some way. If I'm not seeing them, they simply stand in their corner doing nothing.

The zombie-brushes are raised over displacements, could this be a problem? I commited a sin and de-compiled an official map to see if I could find any differences in the method. And well, I didnt see anything special. Tried searching up this problem too, with no luck.

Any help?

Are there any func_safe_zones in your level, at least one?

Zombies pretty much use those as a rally point to get out of their spawn areas first

Share this post


Link to post
Share on other sites

There is one safe_zone yea. The zombies have to walk a pair stairs to get to it though, could that be the problem?

Edited by ashton93

Share this post


Link to post
Share on other sites

Found out of the problem! The origin of the safezone was plotted into a wall, this made the zombies unable to know where to go. So for enyone else getting this issue, the way to solve it is to simply change the origin ;)

EDIT: Turns out this suddenly isnt working anymore. I have no idea why they won't move when they spawn. Any ideas..?

Edited by ashton93

Share this post


Link to post
Share on other sites

Sorry for the triple-post haha, but I did eventually find the solution;

The game (and the zombies) is really picky about the placement of the safezones. I eventually found out that by raising the zone from the floor, and lowering it from the ceiling + making sure the origin is not inside a solid object made the zombies finally head for the zone and navigate correctly!

Edited by ashton93

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0